Šī spraudnis nav atjaunināts vairāk kā divus gadus. Varbūt, tas vairs netiek uzturēts, nesaņemt atbalstu un tam var būt saderības problēmas ar jaunākām WordPress versijām.

Strings Sanitizer

Apraksts

In A Nutshell

Works by converting common accentuated UTF-8 characters, as well as a few special cyrillic, hebrew, spanish and german characters.
Any white space will be replaced by a hyphen, thus generating SEO friendly post slugs, as well as generating Linux-friendly filenames.

Requirements

This plugin requires:

  • WordPress 3.0+
  • PHP 5.1.0+

Praises and Criticisms

Comments, bug reports and feature requests are more then welcome.
Please send you inquiries by email, at wordpress@prospek.ca.

Shameless Plug

Explore more plugins by Prospek, and while you are at it, pay us a little visit.

Uzstādīšana

Install Strings Sanitizer via the WordPress.org plugin directory, or download the latest version, unzip, and place the folder and it’s entire content to the plugins directory of your WordPress installation (most likely in /wp-content/plugins/).

After activating, a new top level menu labelled “Prospek” will appear in the admin menu sidebar, containing a submenu labelled “Strings Sanitizer”.

Select it. Click it. Explore it.

Atsauksmes

Par šo spraudni nav atsauksmju.

Autori un izstrādātāji

“Strings Sanitizer” ir atvērtā pirmkoda programmatūra. Šo spraudni ir veidojuši šādi cilvēki.

Līdzdalībnieki

Tulkot “Strings Sanitizer” savā valodā.

Vai jūs interesē attīstība?

Pārlūkojiet kodu, apmeklējiet SVN krātuvi vai abonējiet attīstības žurnālu, ko izveidojis RSS.

Izmaiņu žurnāls

1.0

  • Initial release
  • ADD: French translations
  • ADD: Added classes/admin_pointers.php helper class
  • ADD: Using new feature pointers from WP 3.3+ upon plugin activation
  • OPT: Code refactoring, optimizations and documentation
  • ADD: Added CSS and webfonts
  • CHG: Successful regression testing, up to WordPress version 2.7
  • CHG: Successful testing on WordPress version 3.4-beta3
  • FIX: Only add filters if we are in admin area, otherwise, it might break the frontend! Wikes.

1.0b4

  • Changes in readme.txt

1.0b3

  • FIX: Fixed constructor, effectively removing dependency to PHP >= 5.3
  • ADD: Added classes/admin_notices.php helper class
  • OPT: Display notice to admins, if PHP >= 5.1 dependency is not met
  • CHG: Changed plugin display name (Prospek Strings Sanitizer -> Strings Sanitizer)
  • ADD: Added WordPress Plugin page header image
  • UPD: Updated plugin description
  • CHG: Successful regression testing, up to WordPress version 2.8

1.0b2

  • FIX: Fixed contributors and short description
  • REM: Removed unneeded logs directory

1.0b1

  • Initial beta release